Error encountered in setup of Care Coordination (CCDA) module

it looks like display_errors is on

1 Like

You’re right Stephen, that seems to be the one setting I missed. I turned it off but am getting no response from the application when I click the config button for the CCDA module.

Also, when installing node.js do I need to install these other tools in order for the module to work?

node_js setup

Following up…

Does anyone know whether I need to install Python and Visual Studio Build Tools during node.js installation for the CCDA module to work?

For ccda install we used to have to compile libxmljs library on windows however I was able to find a compiled version and in most all cases, install shouldn’t have to compiled.
I’d still install the optional compiler and python to be safe for future versions if for some reason we have to go back to compiling that project.


Ok good to know. I’ve installed node.js but I get this message when I try to access the Care Coordination module in OpenEMR:

I followed these steps:

  • CCDA service already enabled
  • Installed node.js
  • Ensured that system variable NODE_PATH is set i.e %USERPROFILE%\AppData\Roaming\npm\node_modules
  • Ran npm install --only=production in ccdaservice directory from command line. This step led to this output:

With your task manager delete any running node processes then try. Could be an old version was already running.

Another way to test is ensure you don’t have any node processes running then cd into ccdaservice directory and run node serveccda
This way any node errors will show in directory terminal.

1 Like

Running node serveccda yields no output for some reason. Just a blank terminal even 15 minutes after running the command.

I decided to start fresh so rolled back my system to a snapshot before my initial CCDA module setup attempt, then followed these steps:

  • Enabled CCDA service in OpenEMR
  • Installed nodejs
  • Set NODE_PATH system variable to %USERPROFILE%\AppData\Roaming\npm\node_modules
  • Ran npm-install --only=production from command line. This is the output (stuck at this step):

The debug log listed at the bottom doesn’t exist. Does anyone have insight on the cause for these errors and how to proceed?

install node version 16.13 or 16.?? we don’t support v18 yet.
I’d also delete current ccdaservice directory and reinstall it after re-install node.
On window recm install NVM so can change node version if one line command.

1 Like

Ahh ok got it, no v18. I re-installed with v16.13.1 and now get this error when running npm install --only=production

Sounds like a firewall issue.

Yeah I don’t know what to tell you. Just need to figure out network issues and probably been the issue all along.

1 Like

No problem, I understand. I found a workaround that resolved the proxy error and tried running the npm install command again. Now I have a new error:

I verified that the package.json file exists in the ccdaservice directory. These are its contents:
package_json file

node.js is not present in the util-deprecate folder

Is this something you might have insight on?

Happy New Year all. Just checking back to see if anyone has any other input on this issue. If not, I’ll close this thread. Thanks!

There shouldn’t be a reason that project build needs to build the libxmljs2 if npm can download from internet. Still though appears compiler can’t reach build tools would be my guess.

When you install node be sure to tick the include environment paths(unsure what it is called as been a long time since I installed for global use).

Also entirely delete the ccdaservice directory and copy/paste or whatever from the v7 install tar/zip.
Then reinstall patch 2.

Try to install ccdaservice again

Do I need to run npm init per these instructions: openemr/ at master · openemr/openemr · GitHub

hi @athenaortiz , did you checkout the CCDA presentation yet? There’s a nice intro on the setup.

1 Like

no that inits a new package. Just the instruction.


I haven’t seen that yet, thanks for sharing.

1 Like

I tried the recommended instructions but am still getting the same results. I noticed the Windows setup instructions ( were updated recently so I tried those:

  1. Downloaded nodejs v18.13.0
  2. Set NODE_PATH system variable to %USERPROFILE%\AppData\Roaming\npm\node_modules
  3. Ran npm install --global --omit=dev windows-build-tools

I’m getting these errors:

Am I missing any steps?