Docker From Dev Tip

installation

(R Magauran) #1

When I run Docker from the dev tip, in the second stage of setup, what is the openemr database password? I thought it was openemr but the validate process requires 12 characters?

Also, root password for database should be root but I am getting an “ERROR . Check your login credentials. unable to connect to database as root” ?


(R Magauran) #2

I remove all the references to “minlength” in setup.php and it proceeds.
The knockout tabs version doesn’t load though, just framed version.


(Brady Miller) #3

hi @rmagauran ,
This should not cause issues with dockers. What docker set up are you running?
-brady


(R Magauran) #4

I am running docker from your master branch, not one of the pre-built dockers, to create a 5.0.2 test environment for a mobile interface.

The setup.php mechanism has changed, requiring 12 characters for usernames and passwords. The install process still uses openemr DB username openemr and password openemr. The username “Admin” with password “pass” is not possible.

I get this for security reason, just that the process changed and needs tweaking.

The knockout version loads, it just couldn’t find the new themes location. Not sure where the link is to the old location but to make the docker work I added the themes directory back in.


(Brady Miller) #5

hi @rmagauran ,

There is something odd going on in your build/config process. Did you build your own docker or use one of the dockers here:
https://hub.docker.com/r/openemr/openemr/

Are you using a docker-compose script? And if so, what does it look like?

-brady


(R Magauran) #6

It was not from a prebuild docker container but from the the master. Using Tower I switched to your master branch. In a terminal window I navigated to your branch on my device, entered the docker directory (openemr/contrib/util/docker) and ran docker-compose up -d.


(Brady Miller) #7

hi @rmagauran ,

First, welcome to the insane docker development environment (yes, that is its name :slight_smile: ):
openemr/contrib/util/docker at master · openemr/openemr · GitHub

Note it makes use of the flex openemr dockers for the magic.
openemr/docker-compose.yml at master · openemr/openemr · GitHub

Regarding the themes, I am guessing you are running it before it is installed. Rec. checking the log to ensure it is done installing/configuring before using:
docker logs docker_openemr-7-2_1

When you run setup, note there are couple things to follow:
openemr/README.md at master · openemr/openemr · GitHub
(check out step 4)

And you can use whatever names you prefer for mysql database name and mysql user name/pass (there is no requirement to use certain names). When I do my development on this, regarding the openemr name/pass I just used what was randomly generated there for the username and copy that to password and copy it to a quick text note file (so I don’t forget it while developing).

-brady


(R Magauran) #8

When i run your master branch, the setup steps are more “modern” whereas other branches use the “old” Setup. But the minlength requirements block setup from progressing - no problem running the docker these branches so far…


(Brady Miller) #9

hi @rmagauran ,
To clarify, you do not have to use openemr/openemr and admin/pass credentials for the mysql user and openemr user, respectively. When you go through the setup, you can can enter in credentials that fulfill the security requirements (ie. maybe use openemropenemr for the openemr mysql user password, and then use the proposed randomly generated openemr username in addition to using it for the password). Note that some docker configuration will also autoinstall openemr (ie. bypass setup) using standard credentials or those set in the docker-compose.yml (the standard openemr dockers do this in addition to the Easy development docker environment: openemr/CONTRIBUTING.md at master · openemr/openemr · GitHub).
-brady