Deprected creation of dynamic property in adodb

you probably just have to rebuild the dockers then and also have to update rel-701 with similar commands if you’re jumping into that branch

is it ‘docker-compose up’ that rebuilds the docker images - or a different command?

first down then up :slight_smile:

ok, i do that regularly, and did try when this problem started, but let me try again…

I’m afraid that’s no better - and i even followed brady’s commands to clean up a local master branch!
Is there a way to tell which version of adodb is loaded in the docker image?

openemr-cmd s
vi composer.lock

then search for adodb

maybe you haven’t pulled a recent openemr docker?

openemr-cmd dpi

it is the correct version

“name”: “adodb/adodb-php”,
“version”: “v5.22.5”,

i can try updating docker too.

sorted :grinning: - went into the db, table globals, and set billing_log_option to 0, and user_debug to 0
(i probably didn’t need to clear billing_log_option btw)

this turned off the deprecated errors, so i was then able to log back in, and change the logging options in the admin/config.

what i wanted is to set system error logging to ‘debug error logging’

the thing that started off all the deprecated error messages was, i think, setting User debug options to all errors

thank you soooo much for your help - and i’m sorry to have gone down so many rabbit holes - i think my problem was not looking at the globals table in the db carefully enough to find the logging setting

The whole point of setting User Debug to All is to show PHP errors that will eventually still appear in the PHP error log.
So check your php error log to verify if error is gone.
There shouldn’t have been a reason to go to globals when you could turn off debug in config.
Unless I’m missing something.

ah yes, the problem was all the depricated error messages were being displayed in the OpenEMR browser window, thus making it impossible to do anything once i’d logged in - see the screen shot at the start of this conversation. logging in wasn’t that easy either!
Perhaps i didn’t make that clear enough in my original post?

i have no problem with error messages in the error log - at least these don’t stop me from testing the system etc. that’s why we went down the php.ini route for a while.

now i have a solution if it happens again, would you like me to test that it was setting user debug options that did cause the problem ?

no idea @ruth , with that adodb package set at v5.22.5 it shouldn’t throw that error and am unable to reproduce it

looking at your log it doesn’t show the easy dev port # of 8300,

referrer: http://localhost:8300/interface/patient_file...

though so not sure you’re running that in your localhost

i do use port 8300 on localhost - this where the openemr application runs - here is the docker ps for that container. You can also see it at the top of the screen shot in my first post.

29d480d35ab1 openemr/openemr:flex “./” 39 minutes ago Up 3 minutes>80/tcp, :::8300->80/tcp,>443/tcp, :::9300->443/tcp development-easy_openemr_1

interesting that you can’t reproduce it. I might try to reproduce it again tomorrow

also more apologies, now i’m back in i checked and i’m actually running 7.0.2-dev!
and in answer to Jerry - there are no deprecated errors in the docker php logs that i can see.

it’s evening here now so i’m going to call it a day…

1 Like

good morning @stephenwaite and @sjpadgett . I can reproduce the problem, so shall i report it as an issue on github?:

I’m using v.7.0.2-dev on SuseLinux, with firefox browser, using docker.

  • set admin/config/logging ‘user debug options’ to ‘ALL’
  • leave ‘system error logging options’ as ‘standard error log’
  • click ‘save’
    the screen then fills with deprecated error messages from adodb as in the screen shot below

to stop this i go into the DB (with phpmyadmin), go to the globals table and reset ‘user-debug’ to 0

tried setting ‘system error logging options’ to ‘debug messages’ - in neither setting for this does anything show up in the docker logs (docker exec -i $(docker ps | grep _openemr | cut -f 1 -d " ") sh -c ‘/root/devtools php-log’)

Hi @ruth , something’s weird in your dev enviro since can’t reproduce on OpenEMR Login

hey ho, thanks steve! no idea what’s going on, but won’t investigate further for now. good to know it’s not affecting other installations.

i did try to update my docker yesterday, but am getting errors for this too:

ruth@localhost:~/software/OpenEMR/openemr> openemr-cmd dpi
Do you wish to pull openemr/openemr:flex ? (y) y
Error response from daemon: Get “”: dial tcp: lookup on no such host

could this be contributing? - again no idea how to fix? - but it’s not stopping me from working


docker pull openemr/openemr:flex

And are you removing the shared volumes when you do the docker down (btw, openemr-cmd down does this automatically)

docker-compose down -v

Thanks Brady,
yes i’m running docker pull openemr/openemr:flex

i did a backup (openemr-cmd bs) followed by a docker down -v (using openemr-cmd down) and then tried the pull command again, with the same result

ruth@localhost:~/software/OpenEMR/openemr/docker/development-easy> docker pull openemr/openemr:flex
Error response from daemon: Get “”: dial tcp: lookup on no such host

there must be something i’m doing wrong. I’m popping out for the morning, but will be working on this again this afternoon. many thanks for your help

sounds like maybe a nameserver issue on your main server:

Hi all,
well, today being a new day my openemr is now running without the deprecated error messages (when i set ‘user debugging options’ to ‘all’) :slight_smile: :

in trying to download the latest dockers following brady’s advice i did a ‘docker down -v’ and i think it is this that must have cleared the problem.
I think this is what Stephen was trying to get me to do (in msg 19) but i didn’t understand well enough.

(unfortunately the backup snapshot i did doesn’t seem to be available so my database is also reset as a clean db. not the end of the world as it only holds test data which i can recreate. I expect i should have used capsules as well as the snapshot - i must look into how these things work! )

thanks as always

1 Like

Snapshots are not persistent (ie. they will go away when you do a down/up in your docker). Capsules are there to make the snapshots persistent (since this basically is a way to save and restore the snapshots to outside the docker environment). Tutorial on this is at: