Connection Reset when saving Global Settings

installation
question

(Debe) #1

I am in the process of installing OpenEMR on a fresh Ubuntu 18.04 VM following these instructions:
https://www.open-emr.org/wiki/index.php/OpenEMR_5.0.2_Linux_Installation.
I made it to the OpenEMR 5.0.2 MU2 Install Instructions (https://www.open-emr.org/wiki/index.php/OpenEMR_5.0.2_MU2_Install_Instructions) but I am not able to save the settings. When I click save, I receive a “The connection was reset” error.
Here’s a screenshot of the issue with the console open:


Here’s a screenshot of my apache error log:

My current setup is as follows:
Ubuntu 18.04 VM (2 cores, 2 GB Ram)
Apache - 2.4
PHP - 7.2
MYSQL - 5.7
Any assistance is greatly appreciated.


(Stephen Waite) #2

hi @mciadmin, can you save any globals?


(Debe) #3

Hi Stephen,
Unfortunately, no. None of the settings are saving.


(Stephen Waite) #4

what are the permissions of the documents directory

ls -lrt sites/default/documents

(Debe) #5

drwx------ 4 www-data www-data 4096 Oct 24 14:24 00
drwxrwxrwx 2 user1 user1 4096 Oct 13 08:47 certificates
drwxrwxrwx 2 user1 user1 4096 Oct 13 08:47 couchdb
drwxrwxrwx 3 user1 user1 4096 Oct 13 08:47 custom_menus
drwxrwxrwx 2 user1 user1 4096 Oct 13 08:47 edi
drwxrwxrwx 2 user1 user1 4096 Oct 13 08:47 era
-rw-rw-rw- 1 user1 user1 30 Oct 13 08:47 .htaccess
drwxrwxrwx 2 user1 user1 4096 Oct 13 08:47 letter_templates
drwxrwxrwx 3 user1 user1 4096 Oct 13 08:47 logs_and_misc
drwxrwxrwx 3 user1 user1 4096 Oct 13 08:47 mpdf
drwxrwxrwx 3 user1 user1 4096 Oct 13 08:47 onsite_portal_documents
drwxrwxrwx 2 user1 user1 4096 Oct 13 08:47 procedure_results
drwxrwxrwx 4 user1 user1 4096 Oct 13 08:47 smarty
drwxrwxrwx 2 user1 user1 4096 Oct 13 08:47 temp


(Stephen Waite) #6

a little too permissive, no? :slight_smile:

try to find something more substantial in the error logs, first configure php
https://www.open-emr.org/wiki/index.php/FAQ#What_are_the_correct_PHP_settings_.28can_be_found_in_the_php.ini_file.29.3F

    error_reporting = E_ALL & ~E_NOTICE & ~E_STRICT 

then restart apache2 and try to save globals and look in the error log


(Debe) #7

Very permissive indeed. Haven’t made it to to the permissions yet.
I am not seeing any errors at all.
This is the php settings:

These are the configs:

Here’s the error log:


(Stephen Waite) #8

Ok, thanks, have you installed the first patch? https://www.open-emr.org/wiki/index.php/OpenEMR_Patches


(Debe) #9

Yes,
I was able to install the 1st patch.


(Debe) #10

Well,
It’s working now. Here’s what I did:

  1. Deleted the openemr directory from /var/www/html/
  2. Re-downloaded the openemr-5.0.2.tar.gz file and extracted it again.
  3. Performed all installation steps without adjusting any configuration (I left the previous configuration untouched).
    a. Selected “I have already created the database” and entered the previous credentials.
  4. It worked.