Is CMOS a GUI of or they are two different ways of making forms, the writer of both is the same person? seems to be outdated and it is running into lots of errors, unless I am doing something wrong?

This is the line 766 where \s was considered unrecognized:

if ($_->[0] !~ /
\s*$|</td>\s*$|</tr>\s*$|</p>\s*$/) {
$return .= ‘

		  $return .= $_->[0]."\n";

Searching \s ( lower case s) it was searching for white space while \S ( uppercase S ) is searching for non white space ( grabbing words letters ….depends on the string of how many characters set in the argument) but why it was unexpected here?

I tried to install perlbrew and reverted to an earlier perl v5.10.1 which matches the time when the script was written but it gave the same error….Was different versions of the script? is there any link to an earlier version that I can run on an older perl installed on my machine?


Credit to Brian from stack overflow

" script is written in perl but contains errors - Stack Overflow"

I posted my question there and brilliant, elegant answer came from him with modifying one line at the end of the script

$_->[0] !~ /

Attached screen shot from my Mac terminal with the error:

$_->[0] !~ m! < (?:br /|/(?:t[rd]|p)) > \s* $!x

Attached screen shot from terminal showing the script is WORKING.

Enjoy this great PEARL script (pun intended) written by Dr. Leeds…!

1 Like