CCDA data won't import

I have exported some 350 patients from practice fusion and I want to import them into OpenEMR but from the 350 I could only import 35 the remaining patients display the rows without the add new patient button.

Any ideas on what I need to do in order to make the add new patient button display so I can import the remaining patients?

Is there an automated way for me to just import them all without having to click add new patient for each and every one of them?

When I click the details button they do in fact have all the data which seems weird.

Also how can I delete these rows that I can’t import?


Doing some digging it seems this page is broken, I can only import 2 ccda records at the same time anything more than that cause this bug/issue where they can’t be imported/deleted.

If I import 2 patients then select 2 other patients they all load even though when I tried uploading more than 2 they break so I know it’s not a CCDA xml issue since they import fine on a one by one basis.

Just some more clues to try to debug this, thanks.

This has been broken for a while. There has not been anyone to pick this up and move it forward.

I did some work in there a few years ago to fix it so the import at least worked again, it wasn’t working at all when I touched it. @sjpadgett is rebuilding the CCDA process for our MU3 certification.

Update: CCDA import works you just have to do it on a 1 by 1 basis :eyes: I know because I just finished importing 344 patients for a client.

I will try to look into this when I get back home and see if there’s something I can do to try and fix it, if anyone has any pointers where I should start looking please let me know.