Can't access server after install - localhost refused to connect


(Christian Fetsch) #1

I’ve done numerous searches to no avail, but please point me in the right direction if I’ve missed a helpful post somewhere…

I have installed OpenEMR on a Kubuntu box, using a VM. I’m doing it this way so I can use remote desktop, just in case I need to access the host box from home, etc.

The Ubuntu VM install went great, I have everything installed, but I can’t access the localhost/openemr webpage.

My internet provider doesn’t allow opening of ports 22, 23, 80, 443, so I have forwarded ports 8080 (for 80) 8443 (for 443) and 1025 (for 22) from the router to my box, to use instead. In the VM, I tried forwarding host 8080 to guest 80, and the others above, but no change. I’ve also tried using a bridged connection setting in the VM, but no change.

I am thinking that the forwarding at the router is the issue that’s preventing me from seeing the OpenEMR webpage, but I can’t find anything to help me figure it out.

Does anyone have any suggestions? Thanks in advance for any input!


(Sherwin Gaddis) #2

I would agree with you that the port forwarding is the issue. Because it depends on if you are trying to access the install from outside the system or from inside the firewall.

You stated that your ISP doesn’t allow certain ports. And if that is try from the outside of the system there is no way around that in my opinion.

You might want to use a port detective software to see what ports you do have open.

Question:
When on the same side of the firewall as the Ubuntu server can you access the software from
localhost:8080/openemr?


(Christian Fetsch) #3

No, I’m unable to connect. Thanks for the idea…

I did try adding LISTEN 8080, LISTEN 8443 to the apache2 file, and I can see it is listening, but no change

I’ve also opened 8080, 8443, 1025 in the Ubuntu firewall, to see if that was the issue, but no change


(Sherwin Gaddis) #4

I have a silly question. Can you connect to http://localhost/openemr?


(Christian Fetsch) #5

No, that doesn’t work either.

I’m checking if there could be a firewall that’s foiling my attempts to set up a server on the network…I’m completely stumped otherwise! I share the connection with other users, so this might be the case.

Any other thoughts?