Calendar in AWS


(Y. Charles) #1

Experiencing an issue with OpenEMR’s calendar on AWS. (500 Full Stack)
When in calendar view with a user selected, click on a future date(or past date) on the left pane.

  • Selected user changes to ‘All Users’.
  • Once on ‘All Users’, ‘Week’ and ‘Month’ selection does not work.
  • Calendar also slows down.
  • Experiencing this issue only with AWS Full Stack deployment.
    Does anyone has a fix for that?
    Thanks

Cloud Express Plus updates/customization
(Brady Miller) #2

hi @ycharles ,

When you click on ‘About’ in OpenEMR, what do you see for the ‘Version Number’ ?

-brady


(Asher Densmore-Lynn) #3

Hello, ycharles.

I just released a new version of Full Stack, which pulls in v5.0.0.7 and does not appear to have the bug you described. If you create a new stack, you can pull the code in, or you can upload a new version of the application into Elastic Beanstalk.

Sorry for the trouble!


(Asher Densmore-Lynn) #4

ycharles,

You’ll find openemr-5.0.0.7-cloud-beanstalk.zip at https://sourceforge.net/projects/openemr/files/OpenEMR%20Cloud/5.0.0/ . I’ve checked for you, and there aren’t any database changes between 5.0.0.5 (which you’re running) and 5.0.0.7 (which fixes the bug), so if you wanted to, you should be able to load this revised beanstalk file into the Elastic Beanstalk application that CloudFormation started. (This is probably good practice anyways, since this is how you’d apply patches or new versions of the software.)


(Y. Charles) #5

Thank brady and jesdynf for the reply.
jesdynf, the calendar in the upgrade works much better.
Now, I can click on the 'Month or ‘Week’ to see the entire month or week.

One problem remains on my install(a fresh one to test 5.0.0.7):

  • Although the Providers selection no longer switches to ‘All Users’ when a date is selected, it will however select all the users together. This is not a problem when 2 or 3 users are displayed on the screen, but can be a nightmare for front desk personnel with more than 3 providers, say 10 or 15. This can really slow down their work as they try to navigate through all these providers. The goal is to be able to select one provider, than a date for the selected provider.

Are you experiencing the same issue? I want to make sure I’m not missing something.
Thanks for your great work.


(Brady Miller) #6

hi @ycharles ,

I wasn’t able to reproduce on the online demo. Are you able to reproduce this on the demo at:
http://www.open-emr.org/wiki/index.php/OpenEMR_Demo

-brady


(Y. Charles) #7

No, I get the problem on an old a fresh install of Full Stack. I don’t get this error on OpenEMR Cloud Express Plus. I suspected the Load Balancer.


(Y. Charles) #8

I connected directly to the session(by VPN), bypassing the load balancer(as I understand it) and the problem is still there. That led me to believe, along with the following link, that Elastic Beanstalk and Smarty is probably the issue. But my field of expertise is networking, not programming.
https://stackoverflow.com/questions/45612708/smarty-files-are-not-recompiled-using-elastic-beanstalk-codepipeline-and-codeco

Let me know what you think.

Thank You!


(Asher Densmore-Lynn) #9

ycharles,

Bypassing the ELB to speak to the webworker was the correct answer, since it confirms the problem isn’t the ELB. At this point, I would assume the problem is going to be something about how the instance is configured. We’re reviewing this now, but something you might do is check the Apache error_log on the instance, to see if you get any hints; failing that, you might find openemr-devops/packages/full_stack/assets/eb at master · openemr/openemr-devops · GitHub instructive – this is the core of the post-launch scripts and configuration used to configure the instance after EB launches a PHP 7.0 webworker.


(Brady Miller) #10

hi @ycharles ,

Another thing to try is in OpenEMR:
Administration->Other->Calendar->Clear Smarty Cache

-brady


(Y. Charles) #11

Yes, thank you. I repeatedly tried to clear the cahe with no success. Looking at jesdynf reply for possible solution.


(Y. Charles) #12

I do get the following errors in the log:

[Wed Jan 10 20:50:27.965653 2018] [:error] [pid 20482] [client 10.0.3.132:27191] PHP Notice: Memcache::connect(): Server 127.0.0.1 (tcp 11211, udp 0) failed with: Connection refused (111) in /var/app/current/openemr/vendor/doctrine/orm/lib/Doctrine/ORM/Tools/Setup.php on line 133, referer: https://nnn.nnnnnnn.org/openemr/interface/main/calendar/index.php?module=PostCalendar&viewtype=day&func=view&pc_username=admin&framewidth=1600

[Wed Jan 10 20:50:27.965681 2018] [:error] [pid 20482] [client 10.0.3.132:27191] PHP Warning: Memcache::connect(): Can’t connect to 127.0.0.1:11211, Connection refused (111) in /var/app/current/openemr/vendor/doctrine/orm/lib/Doctrine/ORM/Tools/Setup.php on line 133, referer: https://nnn.nnnnnn.org/openemr/interface/main/calendar/index.php?module=PostCalendar&viewtype=day&func=view&pc_username=admin&framewidth=1600


(Brady Miller) #13

flagging to @MatthewVita ,

This is really odd since that doctrine orm library is not in OpenEMR 5.0.0

-brady


(Brady Miller) #14

hi @ycharles ,

When you click on ‘About’ in OpenEMR, what do you now see for the ‘Version Number’ ?

-brady


(Y. Charles) #15

Sorry brady! I got this error from the wrong deployment, and does not apply.(v5.0.1-dev)


(Asher Densmore-Lynn) #16

ycharles,

I’m glad to hear you worked out the problem! But I’m also really interested to see that you’re experimenting with the different releases. Can you tell me how you’re doing so? Are you going through the AWS console for the beanstalk deployments, or are you doing it some other way?

Thanks!


(Y. Charles) #17

Sorry for the confusion. I did not find a solution to the problem. While researching it, I accessed a wrong deployment with the errors posted previously.(Too many screens open) So the problem remains.
That being said, the only way I do not get the calendar error is by not using beanstalk. A plain linux deployment, with access to the resources created by OpenEMR Full Stack works for me.


(Y. Charles) #18

Any breakthrough on this issue? No success on my side.

-Y.


(Asher Densmore-Lynn) #19

Hello, ycharles.

I’ve uploaded a new version of OpenEMR using a new version of the Elastic Beanstalk engine. Please let me know if you’re running into this trouble with the generic full stack running in us-east-1, the one launched from clicking on https://console.aws.amazon.com/cloudformation/home?region=us-east-1#/stacks/new?stackName=OpenEMR&templateURL=https://s3.amazonaws.com/openemr-cfn-useast1/OpenEMR.json .

Thanks!


(Y. Charles) #20

Thanks jesdynf. Unfortunately, the problem remains. I have 2 fresh installs, one Express, the other Full Stack(installed today using the link previously provided). I created 2 test providers on them.On the Express calendar, I can click on one provider, click on a date, and it will take me to that date for only the selected provider. This is fine. However on the Full Stack, I do the same, but OEMR will loose the focus on the one provider by selecting all of them before going to the date. This is a big issue when a clinic has 5+ providers.

Thanks again for looking into this.