Building project removes custom theme

I have created a custom theme where I have written the CSS for styling the frontend of our OpenEMR installation. When I run the npm build command this file is removed from the folder with all the other theme stylesheets (public/themes). This is the second time it has happened and all of our styling has been removed (the first time I assumed I made a mistake). Any idea why this happens and how to fix it? Do I need to register custom themes somewhere?

OpenEMR Version
I’m using: OpenEMR version 7.0.1-dev

I’m using: Google Chrome

Operating System
I’m using: MacOS Big Sur 11.6.5

Did you check the logs?
Was there anything pertinent in them?

Didn’t notice anything unusual in the logs or anywhere else.

Figured it out, my styles need to go here: interface/themes/colors/style_theme_name.scss and then the gulp task will build them and put them in the public directory when I run the npm build command


I have a detailed guide on how to build custom themes.