Batch Payments (Payment From) Address Issue


(Ben Zoro) #1

Using 5.0.2(1), when working with Batch Payments, the address for where the insurance payment is from (Payment From) contains USA even though we are in a different country.

image

How can we change that?


( htuck@mi-squared.com) #2

Hi @Benzo I’ll tell you what I suspect which unfortunately isn’t great news.
Batch Payment, the place that provides the ‘payment from’ takes its listing from the insurances company listing, found in Admin/ Practice/ Insurance Company. As the pic shows, the address blank provides no way to select a country so you must supply it as part of the text of the address there. That tells me the ‘,USA’ is added by the code that displays the ‘Payment From’ list. You’d have to get in there and remove the bit that appends ‘, USA’ to the ‘Payment From’ list.
I’d love to be wrong about this but don’t think I am. And I’m not a dev so I can’t tell you where that might be.


(ViSolve) #3

@Benzo

Please check the below file there you can see that USA is set as default value for the country.

File Name : library/classes/Address.class.php

And, there is no option available in the Insurance Company creation UI to get the country.

Whenever, the new insurance created it uses the default value for the country.

So that every insurance company has USA as country.

Batch payments-> Payment From search will results the city,state and country in
the third column. So it gives the USA for every insurance company.

Thanks,
ViSolve-119


(Ben Zoro) #4

Thanks @visolveemr

What happens if the country name is changed?